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Chapter 7  View and Print Site Reports

:  Overview

The Site Module provides many reports for users with the necessary access.  When you select
a report from the Reports menu, the Print Preview window will open.  The Print Preview window
allows you to view the report before actually printing it.  User access to reports is defined on the
Fund Administrator (FA) Module User Maintenance window Site Security Access Reports,
Inquiries access options.  For example, if a user has been assigned No Access on the
Reports, Inquiries  site security access option, that user cannot view documents.  Only users
with Reports, Inquiries Access can view reports.

No matter which report you open, the procedure for viewing and printing a report is the same.
This chapter briefly describes each Site report, details the steps for viewing and printing reports,
and discusses the options available for setting display preferences on the Print Preview window.
The chapter also discusses sorting and filtering data on the Print Preview window and defining
report criteria.

When you select certain reports from the Reports menu, a submenu will display.  The submenu
allows you to refine the data contained in the selected report before you open it.  For example,
for the Document Status Log, you can sort by Document Number, Expense Element, Job Order,
or Local Code from the submenu.

To open the Print Preview window, select the desired report from the Reports menu.  If the
desired report has a submenu that allows you to categorize the report, such as by Document
Number, Expense Element, Job Order, or Local Code, select the desired submenu item.

Restrictions

• Only users with a FASTDATA FA Module Site Security Access option of Access under
Reports, Inquiries can view and print Site reports.

• A FASTDATA FA Module Site Security Access option of No Access under Reports,
Inquiries prevents a user from accessing the Site reports.

Figure 7.1
Reports Menu
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• Print Preview Window and Toolbar
The Print Preview window displays the report selected from the Reports menu.  With the Print
Preview window open, the View menu offers Filter and Sort options for most reports.
Additionally, the View menu contains a Criteria option that allows you to further refine the data
in the report.  In addition to the windows used for filtering, the Print Preview window toolbar
contains buttons that allow you to change display options, print the report, and save the report
to a file.

P Print Preview Window Options

• View and print Site reports

• Use Print Preview window toolbar buttons

• Define report criteria

• Filter report data

• Sort report data

n  Steps for Viewing and Printing Site Reports

1. Select the desired report from the Reports menu and choose the appropriate
submenu item, if applicable.

Figure 7.2
Selecting a
Report to
View and
Print
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The Report Criteria window will open automatically before the report displays.  Steps
for defining report criteria are explained in detail in a later section of this chapter.
Enter the desired criteria and select the OK button to close the Report Criteria
window.  You can also select the Cancel button to close the window.  If you close
the Report Criteria window without designating any criteria, the selected report will
contain all available information.

After the Report Criteria window closes, the Print Preview window for the selected
report will open and display the data.

2. If desired, apply additional filtering criteria and data sort preferences to the
displayed report prior to printing it.

Refer to the applicable sections of this chapter for details on using the Filter window
and the Sort window.

3. Use the horizontal and vertical scrollbars on the Print Preview window to change
the view of the displayed report page.

Tip  The scrollbars only allow you to scroll the displayed page.  Use the VCR buttons
to select a different page to view.

4. Select the window-specific Print toolbar button to print the report.

Tip  If you wish to print the entire report, select the Print toolbar button.  If you wish
to print specific pages rather than the whole report, select the File menu Print item.
The Print window will open and allow you to specify the page(s) you wish to print.

5. Select the Close toolbar button or select Close from the File menu to close the
Print Preview window.

Figure 7.3
Print
Preview
Window
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Site Reports
The following paragraphs contain brief summaries of each Site report, by category, along with
samples of selected reports within each category.

Status of Funds Reports
The Status of Funds Reports provide a report of the status of direct or reimbursable funds by
operating target (OPTAR) ID or OPTAR Name.  The reports can be displayed in detailed or
summary format.

Figure 7.5
Print Preview for
Status of Funds
Report

Figure 7.4
Status of Funds
Reports
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Document Status Log Reports
The Document Status Log reports provide a status of each transaction entered, a description of
the transaction, and detailed totals at selected levels.  The reports can be sorted by Document
Number, Expense Element, Job Order, or Local Code.

Figure 7.6
Document Status Log
Reports

Figure 7.7
Print Preview for
FASTDATA Document
Status Log Report
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OPTAR Log / Memorandum Record Report
The OPTAR Log / Memorandum Record report provides detailed accounting information for
each transaction with a running OPTAR balance by date entered.

Figure 7.8
OPTAR Log /
Memorandum
Record Report

Figure 7.9
Print Preview for
OPTAR Log /
Memorandum Record
Report
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OPTAR Requisition Reports
The OPTAR Requisition reports provide supply-type information for each transaction within the
specified reporting period.  The reports can be sorted by Document Number, Expense Element,
Job Order, or Local Code.  The OPTAR Requisition Report does not include labor documents.

Figure 7.10
OPTAR Requisition
Reports

Figure 7.11
Print Preview for
OPTAR Requisition
Report
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Outstanding OPTAR Requisition (No Final Receipts) Reports
The Outstanding OPTAR Requisition (No Final Receipts) reports provide supply-type
information for each transaction for which materials or services have not been received and
which do not have a final receipt posted against them.  The reports can be sorted by Document
Number, Expense Element, Job Order, or Local Code.

Figure 7.12
Outstanding OPTAR
Requisition Reports
(No Final Receipts)

Figure 7.13
Print Preview for
Outstanding OPTAR
Requisition Report
(No Final Receipts)
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Outstanding OPTAR Requisition (No Final Expenditures) Reports
The Outstanding OPTAR Requisition (No Final Expenditures) reports provide supply-type
information for each transaction for which materials or services have not been received and
which do not have a final expenditure posted against them.  The reports can be sorted by
Document Number, Expense Element, Job Order, or Local Code.

Figure 7.14
Outstanding OPTAR
Requisition Reports
(No Final
Expenditures)

Figure 7.15
Print Preview for
Outstanding OPTAR
Requisition Report (No
Final Expenditures)
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Outstanding OPTAR Requisition (No Final Receipts, Expenditures) Reports
The Outstanding OPTAR Requisition (No Final Receipts, Expenditures) reports provide supply-
type information for each transaction for which materials or services have not been received and
which do not have a final receipt or expenditure posted against them.  The reports can be sorted
by Document Number, Expense Element, Job Order, or by Local Code.

Figure 7.16
Outstanding OPTAR
Requisition Reports
(No Final Receipts or
Expenditures)

Figure 7.17
Print Preview for
Outstanding OPTAR
Requisition Report
(No Final Receipts or
Expenditures)
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Document Control Log Report
The Document Control Log report provides a listing of all transactions, grouped by document
type.

Figure 7.18
Document Control
Log Report

Figure 7.19
Print Preview for
Document Control
Log Report
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Contract/DCN Cross Reference Report
The Contract/DCN Cross Reference Report provides a listing of Contract Number/PIIN(s) and
associated DCN/ACRN(s).

Transaction History Report
The Transaction History report provides the complete history of all transactions for a specific
DCN/ACRN.

Figure 7.22
Transaction
History Report

Figure 7.20
Contract/DCN Cross
Reference Report

Figure 7.21
Print Preview for
Contract/DCN Cross
Reference Report



Chapter 7 •  View and Print Site Reports

October 1999 7 – 13 FASTDATA Site Module User’s Manual

Transaction Report
The Transaction Report provides a complete history of transactions for the selected transaction
type(s).

Figure 7.23
Print Preview for
Transaction History
Report

Figure 7.24
Transaction Report

Figure 7.25
Print Preview for
Transaction Report
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Accounting Transaction Batch Report
The Accounting Transaction Batch Report provides a summary of exported and/or ready-for-
export (current) transactions by selected batch number.

Figure 7.27
Print Preview for
Accounting
Transaction Batch
Report

Figure 7.26
Accounting
Transaction Batch
Report
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Non-Preceded Expenditures Reports
The Non-Preceded Expenditures reports provide information on expenditures that were
imported from the FA or entered manually and that do not have a matching obligation.  The
reports can be sorted by Batch Number, Document Number, or Job Order.

Figure 7.28
Non-Preceded
Expenditures
Reports

Figure 7.29
Print Preview for Non-
Preceded
Expenditures Report
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Expenditures Exceeding Variance Reports
The Expenditures Exceeding Variance reports provide information on expenditures the FA
exported to the site or that were entered manually and that exceed the acceptable level of
variance.  The FA establishes variance percentages and amount criteria for each RC and
exports this data to the site.  The reports can be sorted by Batch Number, Document Number,
or Job Order.

Figure 7.30
Expenditures
Exceeding Variance
Reports

Figure 7.31
Print Preview for
Expenditures
Exceeding Variance
Report
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Aviation Fuel Consumption Report
The Aviation Fuel Consumption Report provides a summary of types of fuels utilized, as well as
total costs.

Figure 7.32
Aviation Fuel
Consumption Report

Figure 7.33
Print Preview for
Aviation Fuel
Consumption Report
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n  Using Print Preview Toolbar Buttons

The Print Preview window toolbar provides shortcuts to File and View menu options
for changing the window display and saving the report.

Save As
Select this button to open the Save As window.  Select the file and folder in which
you wish to save the report, enter the File name, and select the Save button to save
the displayed report as a file.  The Save As option is also available from the File
menu.

Print
Select this button to print the report displayed in the Print Preview window.

Figure 7.35
Save As
Window

Figure 7.34
Print Preview
Toolbar
Buttons

Last

Close

First

Zoom

Previous

Next

Margin
Offset

Save As

Ruler

Print
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Ruler
Select this button to enable or disable the Print Preview window ruler.  If the ruler is
enabled when you select this button, it will disappear; if the ruler is disabled when
you select this button, the ruler will display.  The Ruler option is also available from
the View menu.

Margin Offset
Select this button if you wish to adjust margins to allow space for punching holes if
you wish to put the printed report in a binder.  For portrait orientation, enabling this
check box will increase the left margin; for landscape, the top margin will increase.
The Margin Offset option is also available from the View menu.

First
Select this button to access the first page of the displayed report.  This option is also
available from the View menu.

Previous
Select this button to access the previous page of the displayed report.  This option is
also available from the View menu.

Next
Select this button to access the next page of the displayed report.  This option is also
available from the View menu.

Last
Select this button to access the last page of the displayed report.  This option is also
available from the View menu.

Figure 7.36
Print Preview
Window With
Rulers Enabled
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Zoom
Select this button to open the Zoom window.  Select the desired magnification from
the Zoom To list or use the Percent spin buttons to change the degree of
magnification of the displayed report.  The Preview window will allow you to view
your change instantaneously.  Select the Apply button to view your change without
closing the Zoom window or select the OK button to close the Zoom window.  The
Zoom option is also available from the View menu.

Close
Select this button to close the Print Preview window.  The Close option is also
available from the File menu.

n  Steps for Defining Report Criteria

The Report Criteria window opens automatically when you open FASTDATA Site
reports.  You can also open this window by selecting the View menu Criteria item
from the Print Preview window.  Use the Report Criteria window to limit the data
contained in the selected report.

Figure 7.37
Zoom Window
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1. Select the desired report criteria from the available columns drop-down lists.  The
column titles, as well as the number of columns, depend on the report you’re
opening.

In the example shown, the user has selected OPTAR ID RW.  When the Report
Criteria window closes, the report will only include data for OPTAR ID RW.

2. If you do not wish to filter the report, select the Cancel button to close the Report
Criteria window.

If you close the Report Criteria window without designating any criteria, the selected
report will contain all available information.

3. Select the OK button.  The Report Criteria window will close and the selected
report will display.

n  Steps for Filtering Report Data

Use the Filter window to control the data that displays for the selected report.  The
Filter window is available for any report, with the exception of the OPTAR/Memo Log
Report, displayed on the Print Preview window.

1. With the desired report displayed in the Print Preview window, select Filter from
the View menu.

Figure 7.39
Opening the
Filter
Window

Figure 7.38
Entering
Report
Criteria Data
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The Filter window for the selected report will open.

When you use the Filter window, any data you defined as criteria on the Report
Criteria window will not be available on the Filter window.  The tabs on the Filter
window allow you to pick and choose the data and operators you can use in building
an expression for a report filter.  The Functions tab provides further information on
the syntax required for the selected function.

2. If you wish to enter the filter expression manually, enter the desired expression in
the Filter expression text field.

You can specify a range of values, multiple values, or values you wish to exclude in
your filter expression by using operators, which are symbols or words that control
how FASTDATA handles the filter values.  When entering filter expressions, enclose
FASTDATA codes and letters in single or double quotation marks.  Do not enclose
numeric values in quotation marks.

The ( and ) mark the beginning and ending of a logical grouping of expressions.

You can filter for multiple values in a field using or.  For example, you could enter
value 1 or value 2 in your filter expression.  When you select OK on the Filter
window, FASTDATA will filter the report so only values that match each of these
values display in the report.

To exclude values from the report, use not before the value you wish to exclude.
For example, in your filter expression, not Value 1 will filter the value from the report.
When you select OK on the Filter window, FASTDATA will exclude the defined value
in the displayed report.

To filter using relational operators, such as greater than or less than, use these
symbols with the desired value:  >, <, <>, >=, or <= in your filter expression.  For
example, enter > value 1 in your filter expression.  When you select OK on the Filter
window, FASTDATA will return the desired values in the displayed report.

Figure 7.40
Sample
Filter
Window
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Example:  On the Status of Funds report by OPTAR ID, to exclude all labor
transactions, enter fastdata_fs_auth_labor_cd = ‘N’  in the Filter expression  field.

3. If you wish to enter a filter expression with FASTDATA assistance, select the
desired Columns , Operators , and Values  from the Components  tab, then
select the desired functions from the Functions  tab.  The selected items will
appear in the Filter expression  field.

The tabs on the Filter window allow you to pick and choose the data and operators
you can use in building an expression for a report filter.  The Components  tab
provides lists of column names, operators, and values from which you can build a
filter expression.  The Functions  tab lists functions and their syntax.

The Columns  list box displays the column names available for use in filtering the
selected report.  Double-click to select the desired column name.  The selected
column name will appear in the Filter expression  field.  The Operators  list box lists
the available operators.  Double-click the desired operator.  The selected operator
will appear in the Filter expression  field.  The Values  list box displays the values
available in the database for the selected column.  The column name will appear at
the top of the list; available values follow.  Double-click the desired value.  The
selected value will appear in the Filter expression  field.

In addition to the column names shown in the Filter window Columns list box, there
are additional columns available for filtering the Status of Funds reports.  These
column names do not display in the Columns list box so if you wish to use one or
more of these column names, you must enter them into the Filter expression
manually.

Figure 7.41
Manually
Entering Filter
Expression
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Additional Columns Available for the
Status of Funds Report by OPTAR ID

Additional Columns Available for the
Status of Funds Report by OPTAR
Name

annual_planning_amt annual_planning_amt
current_authorized_amt current_authorized_amt
obligated_amt obligated_amt
Balance_amt Balance_amt
Obligated_pct Obligated_pct

On the Functions tab, double-click on the desired function from the list on the left
and select the desired syntax from the list on the right.  The selected function will
appear in the Filter expression field.

Example:  To include only authorization numbers with a value greater than P10020
in the Status of Funds Report by OPTAR ID, select Auth from the Components tab
Columns list box.  Double-click on > in the Operators list box, then select P10020
from the Values list box.  The resulting expression,
fastdata_fs_auth_authorization_id > ’P10020’, will generate a report that excludes
authorizations numbers below P10020.

4. Select the Verify button if you wish to validate the expression in the Filter
expression field.  FASTDATA will inform you that the expression is either valid
or invalid.  Select the OK button to acknowledge the message.

Figure 7.42
Entering a Filter
Expression with
FASTDATA
Assistance
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5. Select the OK button to apply the filter to the report.  The Filter window will close.
The Print Preview window for the selected report displays the filtered data.

n  Steps for Sorting Report Data

The Sort window is available while viewing any report, with the exception of the
OPTAR/Memo Log and Transaction History reports, in the Print Preview window.
Use the window to sort the data in the displayed report.

1. With the desired report displayed in the Print Preview window, select Sort from
the View menu.

Figure 7.44
Opening the
Sort Window

Figure 7.43
FASTDATA
Site Report
with Filtered
Data
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The Sort window will open.  The column names that appear in the Columns
Available for Sorting list box depend on the Site report you currently have open.
Values displayed in the Sort Columns list box indicate the default values by which
the selected report is currently sorted.

2. On the Columns Available for Sorting list box, left-click on a column name;
holding the mouse button down, drag the name to the Sort Columns list box and
release the mouse button.

If you wish to change the default values, you can remove Sort Columns names by
dragging them to the Columns Available for Sorting list box.

3. Disable the Ascending check box if you wish to sort column values in
descending order.

If the Ascending check box is checked, column values display in ascending order; if
unchecked, column values display in descending order.

4. Select the OK button to close the Sort window.

Figure 7.45
Sort Window

Figure 7.46
Sorting Report
Data
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For the sort example shown in Figure 7-46, FASTDATA will display the report with
the Job Order Number column data listed in descending order.

Figure 7.47
Sorted Data
Display


